Zaloguj się Załóż konto
Odpowiedz 
Problem z Google SEO URL - brak linków do wątków
27.05.2010, 19:52
Post: #1
Problem z Google SEO URL - brak linków do wątków
Witam!

Kilka szczegółów o moim forum:
wersja skryptu MyBB: 1.4.13
adres forum: http://www.partacze.net
opis problemu: Nie wyświetlanie wątków po kliknęciu w link na portalu

Na forum mam juz kilkanascie postow. Ustawienia SEO URL mam wlaczone i ustawione przedrostki Forum, Thread itp. Po ich usunieciu i wgraniu poprawionego kodu do .htaccess wszystkie istniejace watki na portalu sa widoczne ale nie mozna w nie wejsc - tzn pokazuje sie przekierowanie ze watek nie istnieje. Prosze o pomoc. W tej chwili przywrocilem przedrostki z powrotem aby wszystkie posty sie wyswietlaly.

Czyli po krotce. Mialem (mam dalej) w .htaccess taki kod:

Kod:
# Google SEO URL Forums:
RewriteRule ^Forum-([^./]+)$ forumdisplay.php?google_seo_forum=$1 [L,QSA,NC]

# Google SEO URL Threads:
RewriteRule ^Thread-([^./]+)$ showthread.php?google_seo_thread=$1 [L,QSA,NC]

# Google SEO URL Announcements:
RewriteRule ^Announcement-([^./]+)$ announcements.php?google_seo_announcement=$1 [L,QSA,NC]

# Google SEO URL Users:
RewriteRule ^User-([^./]+)$ member.php?action=profile&google_seo_user=$1 [L,QSA,NC]

# Google SEO URL Calendars:
RewriteRule ^Calendar-([^./]+)$ calendar.php?google_seo_calendar=$1 [L,QSA,NC]

# Google SEO URL Events:
RewriteRule ^Event-([^./]+)$ calendar.php?action=event&google_seo_event=$1 [L,QSA,NC]

Po usunieciu przedrostkow w ustawieniach pluginu wrzucilem zas ponizszy kod.
Po wprowadzeniu go jednak nie da sie wejsc do zadnego posta na forum:
Zakladam ze kolejne posty pisane z takimi ustawieniami dzialalyby juz normalnie. Ale chce zeby takze wszystkie wstecz dzialaly.

Kod:
# Google SEO URL Forums:
RewriteRule ^([^./]+)$ forumdisplay.php?google_seo_forum=$1 [L,QSA,NC]

# Google SEO URL Threads:
RewriteRule ^([^./]+)$ showthread.php?google_seo_thread=$1 [L,QSA,NC]

# Google SEO URL Announcements:
RewriteRule ^([^./]+)$ announcements.php?google_seo_announcement=$1 [L,QSA,NC]

# Google SEO URL Users:
RewriteRule ^([^./]+)$ member.php?action=profile&google_seo_user=$1 [L,QSA,NC]

# Google SEO URL Calendars:
RewriteRule ^([^./]+)$ calendar.php?google_seo_calendar=$1 [L,QSA,NC]

# Google SEO URL Events:
RewriteRule ^([^./]+)$ calendar.php?action=event&google_seo_event=$1 [L,QSA,NC]
Znajdź wszystkie posty użytkownika
Odpowiedz cytując ten post
27.05.2010, 20:31
Post: #2
RE: Problem z Google SEO URL - brak linków do wątków
Nie zauważyłem żadnych problemów z błędnymi linkami. Gdzie one dokładnie występują?

Znajdź nas na: Facebooku/Google+ | Download
Pomogłem? [kliknij] Smile

Odwiedź stronę użytkownika Znajdź wszystkie posty użytkownika
Odpowiedz cytując ten post
Odpowiedz 


Skocz do:


Użytkownicy przeglądający ten wątek: 1 gości



Forum MyBBsite.pl wykorzystuje cookies. Korzystanie z witryny oznacza zgodę na ich zapis lub wykorzystanie, więcej informacji w polityce prywatności
Akceptuję politykę prywatność, zamknij informację